FLASHBACK - Last year, Pelosi said the federal government "cannot require someone to be vaccinated"

First published at 19:48 UTC on July 30th, 2021.

FLASHBACK - Last year, Pelosi said the federal government "cannot require someone to be vaccinated," saying "it's a matter of privacy."

@disclosetv

https://t.me/disclosetv/3746

CategoryNews & Politics
SensitivityNormal - Content that is suitable for ages 16 and over