Pelosi - We can NOT require vaccines. We can NOT invade privacy.

First published at 16:23 UTC on September 10th, 2021.

FondoBits

FondoBits

subscribers

I'm old enough to remember not that long ago when Nasty Nancy said that the government could NOT require vaccines and could NOT invade people's privacy.

CategoryNews & Politics
SensitivityNormal - Content that is suitable for ages 16 and over